I am using AWS Amplify to host Angular App. Everything was working fine till Friday 3rd June but after that my build’s are failing with Timed out error. Build’s are also not going beyond ES5 bundle generation complete step. Attached are error logs

Error 1

Error 2

Yogesh Rathod is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

1

Hi I’m having the same issue:

Build settings:

Build image: Amazon Linux 2
Build timeout: 30
Amplify CLI: 4.52.0

amplify.yml

version: 1
applications:
  - appRoot: angular
    backend:
      phases:
        build:
          commands:
            - amplifyPush --simple
    frontend:
      phases:
        preBuild:
          commands:
            - nvm use $VERSION_NODE_14
            - npm install
            - npm install -g @angular/cli
        build:
          commands:
            - nvm use $VERSION_NODE_14
            - ng build --configuration=$BUILD_ENV --aot --vendor-chunk --common-chunk --delete-output-path --buildOptimizer
      artifacts:
        baseDirectory: dist/myapp
        files:
          - '**/*'
      cache:
        paths:
          - node_modules/**/*

Error:

Build failed to complete successfully. Reason: Build timed out

                                # Starting phase: build
2022-06-06T20:04:49.212Z [INFO]: # Executing command: nvm use 14
2022-06-06T20:04:49.447Z [INFO]: Now using node v14.19.0 (npm v6.14.16)
2022-06-06T20:04:49.447Z [INFO]: # Executing command: ng build --configuration=production --aot --vendor-chunk --common-chunk --delete-output-path --buildOptimizer
2022-06-06T20:04:50.017Z [WARNING]: Your global Angular CLI version (14.0.0) is greater than your local version (10.1.7). The local Angular CLI version is used.
                                    To disable this warning use "ng config -g cli.warnings.versionMismatch false".
2022-06-06T20:04:51.760Z [WARNING]: Option "extractCss" is deprecated: Deprecated since version 11.0. No longer required to disable CSS extraction for HMR.
2022-06-06T20:04:51.760Z [WARNING]: 
2022-06-06T20:04:54.790Z [WARNING]: Compiling @angular/core : es2015 as esm2015
2022-06-06T20:04:54.956Z [WARNING]: Compiling @angular/cdk/keycodes : es2015 as esm2015
2022-06-06T20:04:54.989Z [WARNING]: Compiling @angular/animations : es2015 as esm2015
2022-06-06T20:04:58.596Z [WARNING]: Compiling @angular/common : es2015 as esm2015
2022-06-06T20:04:58.598Z [WARNING]: Compiling @angular/cdk/observers : es2015 as esm2015
                                    Compiling @angular/animations/browser : es2015 as esm2015
2022-06-06T20:04:59.585Z [WARNING]: Compiling @angular/cdk/platform : es2015 as esm2015
2022-06-06T20:04:59.857Z [WARNING]: Compiling @angular/platform-browser : es2015 as esm2015
2022-06-06T20:04:59.932Z [WARNING]: Compiling @angular/forms : es2015 as esm2015
2022-06-06T20:05:00.363Z [WARNING]: Compiling @angular/cdk/bidi : es2015 as esm2015
2022-06-06T20:05:00.697Z [WARNING]: Compiling @angular/cdk/a11y : es2015 as esm2015
2022-06-06T20:05:00.726Z [WARNING]: Compiling @angular/platform-browser/animations : es2015 as esm2015
2022-06-06T20:05:00.773Z [WARNING]: Compiling @angular/cdk/collections : es2015 as esm2015
2022-06-06T20:05:00.966Z [WARNING]: Compiling @angular/cdk/scrolling : es2015 as esm2015
2022-06-06T20:05:01.070Z [WARNING]: Compiling @angular/cdk/portal : es2015 as esm2015
2022-06-06T20:05:01.322Z [WARNING]: Compiling @angular/material/core : es2015 as esm2015
2022-06-06T20:05:01.350Z [WARNING]: Compiling @ngrx/store : es2015 as esm2015
2022-06-06T20:05:01.644Z [WARNING]: Compiling @angular/cdk/overlay : es2015 as esm2015
2022-06-06T20:05:02.073Z [WARNING]: Compiling @angular/cdk/text-field : es2015 as esm2015
2022-06-06T20:05:02.286Z [WARNING]: Compiling @angular/material/form-field : es2015 as esm2015
2022-06-06T20:05:02.308Z [WARNING]: Compiling @angular/platform-browser-dynamic : es2015 as esm2015
2022-06-06T20:05:02.489Z [WARNING]: Compiling @angular/common/http : es2015 as esm2015
2022-06-06T20:05:02.834Z [WARNING]: Compiling @angular/router : es2015 as esm2015
2022-06-06T20:05:02.928Z [WARNING]: Compiling @ngrx/store-devtools : es2015 as esm2015
2022-06-06T20:05:03.028Z [WARNING]: Compiling @angular/material/autocomplete : es2015 as esm2015
2022-06-06T20:05:03.374Z [WARNING]: Compiling @almothafar/angular-signature-pad : es2015 as esm2015
2022-06-06T20:05:03.554Z [WARNING]: Compiling ngx-webcam : es2015 as esm2015
2022-06-06T20:05:03.608Z [WARNING]: Compiling @angular/material/select : es2015 as esm2015
2022-06-06T20:05:03.756Z [WARNING]: Compiling @angular/material/input : es2015 as esm2015
2022-06-06T20:05:03.875Z [WARNING]: Compiling ng2-charts : es2015 as esm2015
2022-06-06T20:05:04.080Z [WARNING]: Compiling ngx-captcha : es2015 as esm2015
2022-06-06T20:05:04.200Z [WARNING]: Compiling ngx-quill : es2015 as esm2015
2022-06-06T20:05:04.378Z [WARNING]: Compiling ngx-extended-pdf-viewer : es2015 as esm2015
2022-06-06T20:05:04.427Z [WARNING]: Compiling @iplab/ngx-color-picker : es2015 as esm2015
2022-06-06T20:05:05.690Z [WARNING]: - Generating browser application bundles...
2022-06-06T20:06:41.022Z [WARNING]: ✔ Browser application bundle generation complete.