Is there is a way or tool to fix angular build warnings or to simplify the manual process?

I am getting a lot of warnings when building my angular application and I am not really comfortable with this.

Can anyone suggest any tools or ideas that can help or just to simplify the manual procedures?

In general i would like eliminate all incorrect peer dependencies first and if there is a possibility to solve other that would be more than perfect

I’ve been trying for more than a week and
I’m using yarn

yarn install v1.22.19
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
[4/5] Linking dependencies...
warning " > @angular-cool/inline-edit-field@1.0.3" has incorrect peer dependency "@angular/common@^7.0.0".
warning " > @angular-cool/inline-edit-field@1.0.3" has incorrect peer dependency "@angular/core@^7.0.0".
warning " > @angular-cool/inline-edit-field@1.0.3" has incorrect peer dependency "@fortawesome/angular-fontawesome@^0.2.1".
warning " > @angular-cool/inline-edit-field@1.0.3" has unmet peer dependency "@fortawesome/free-regular-svg-icons@^5.6.0".
warning " > @angular/animations@12.0.0-next.3" has incorrect peer dependency "@angular/core@12.0.0-next.3".
warning " > @angular/common@12.0.0-next.3" has incorrect peer dependency "@angular/core@12.0.0-next.3".
warning " > @angular/forms@12.0.0-next.3" has incorrect peer dependency "@angular/core@12.0.0-next.3".
warning " > @angular/google-maps@12.1.1" has incorrect peer dependency "@angular/common@^12.0.0 || ^13.0.0-0".
warning " > @angular/platform-browser@12.0.0-next.3" has incorrect peer dependency "@angular/core@12.0.0-next.3".
warning " > @angular/platform-browser-dynamic@12.0.0-next.3" has incorrect peer dependency "@angular/core@12.0.0-next.3".
warning " > @angular/router@12.0.0-next.3" has incorrect peer dependency "@angular/core@12.0.0-next.3".
warning " > @fortawesome/angular-fontawesome@0.5.0" has incorrect peer dependency "@angular/core@^8.0.0-rc.5".
warning " > @fullcalendar/angular@4.4.2" has incorrect peer dependency "@angular/core@>=7.0.0 <9.0.0".
warning " > @fullcalendar/angular@4.4.2" has incorrect peer dependency "@angular/common@>=7.0.0 <9.0.0".
warning " > @ng-select/ng-select@2.20.5" has incorrect peer dependency "@angular/common@>=6.0.0 <8.0.0".
warning " > @ng-select/ng-select@2.20.5" has incorrect peer dependency "@angular/core@>=6.0.0 <8.0.0".
warning " > @ng-select/ng-select@2.20.5" has incorrect peer dependency "@angular/forms@>=6.0.0 <8.0.0".
warning " > css-loader@3.4.0" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
warning " > style-loader@1.1.2" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
warning " > @savantly/ngx-inline-edit@0.3.0" has incorrect peer dependency "@angular/cdk@~2.0.0-beta.12".
warning " > @savantly/ngx-inline-edit@0.3.0" has unmet peer dependency "@angular/http@>=4".
warning " > @savantly/ngx-inline-edit@0.3.0" has incorrect peer dependency "@angular/material@~2.0.0-beta.12".
warning " > @savantly/ngx-inline-edit@0.3.0" has incorrect peer dependency "core-js@^2.4.1".
warning " > @savantly/ngx-inline-edit@0.3.0" has incorrect peer dependency "rxjs@^5.5.2".
warning " > @savantly/ngx-inline-edit@0.3.0" has incorrect peer dependency "zone.js@^0.8.14".
warning "@savantly/ngx-inline-edit > @angular/cdk@2.0.0-beta.12" has incorrect peer dependency "@angular/core@~4.4.4".
warning "@savantly/ngx-inline-edit > @angular/cdk@2.0.0-beta.12" has incorrect peer dependency "@angular/common@~4.4.4".
warning "@savantly/ngx-inline-edit > @angular/core@8.2.14" has incorrect peer dependency "zone.js@~0.9.1".
warning "@savantly/ngx-inline-edit > @angular/http@7.2.15" has incorrect peer dependency "@angular/core@7.2.15".
warning "@savantly/ngx-inline-edit > @angular/http@7.2.15" has incorrect peer dependency "@angular/platform-browser@7.2.15".
warning "@savantly/ngx-inline-edit > @angular/material@2.0.0-beta.12" has incorrect peer dependency "@angular/core@~4.4.4".
warning "@savantly/ngx-inline-edit > @angular/material@2.0.0-beta.12" has incorrect peer dependency "@angular/common@~4.4.4".
warning " > @swimlane/ngx-datatable@16.0.2" has incorrect peer dependency "@angular/common@<9.0.0".
warning " > @swimlane/ngx-datatable@16.0.2" has incorrect peer dependency "@angular/core@<9.0.0".
warning " > @swimlane/ngx-datatable@16.0.2" has incorrect peer dependency "@angular/platform-browser@<9.0.0".
warning " > bootstrap@4.3.1" has unmet peer dependency "jquery@1.9.1 - 3".
warning " > bootstrap4@4.3.1" has unmet peer dependency "jquery@1.9.1 - 3".
warning " > inline-edit-directive@1.0.2" has incorrect peer dependency "@angular/common@^7.1.0".
warning " > inline-edit-directive@1.0.2" has incorrect peer dependency "@angular/core@^7.1.0".
warning " > ng-pick-datetime@7.0.0" has incorrect peer dependency "@angular/cdk@^7.0.0".
warning " > ng-pick-datetime-moment@1.0.8" has incorrect peer dependency "@angular/animations@^7.0.0".
warning " > ng-pick-datetime-moment@1.0.8" has incorrect peer dependency "@angular/common@^7.0.0".
warning " > ng-pick-datetime-moment@1.0.8" has incorrect peer dependency "@angular/core@^7.0.0".
warning " > ng-pick-datetime-moment@1.0.8" has incorrect peer dependency "@angular/forms@^7.0.0".
warning "ng-pick-datetime-moment > @angular/core@7.2.16" has incorrect peer dependency "zone.js@~0.8.26".
warning "ng-pick-datetime-moment > @angular/forms@7.2.16" has incorrect peer dependency "@angular/platform-browser@7.2.16".
warning " > ngx-color@5.1.2" has unmet peer dependency "tslib@^1.10.0".
warning " > ngx-intl-tel-input@3.1.3" has incorrect peer dependency "ngx-bootstrap@^6.0.0".
warning " > ngx-mat-select-search@2.1.1" has incorrect peer dependency "@angular/material@^8.0.0 || ^9.0.0".
warning " > ngx-quill@7.3.11" has incorrect peer dependency "@angular/common@^7.0.0 || ^8.0.0".
warning " > ngx-quill@7.3.11" has incorrect peer dependency "@angular/core@^7.0.0 || ^8.0.0".
warning " > ngx-quill@7.3.11" has incorrect peer dependency "@angular/forms@^7.0.0 || ^8.0.0".
warning " > ngx-quill@7.3.11" has incorrect peer dependency "@angular/platform-browser@^7.0.0 || ^8.0.0".
warning " > ngx-ui-switch@9.0.1" has incorrect peer dependency "@angular/core@>=5.0.0 <10.0.0".
warning " > ngx-ui-switch@9.0.1" has incorrect peer dependency "@angular/common@>=5.0.0 <10.0.0".
warning " > ngx-ui-switch@9.0.1" has incorrect peer dependency "@angular/forms@>=5.0.0 <10.0.0".
warning " > sass-loader@8.0.0" has unmet peer dependency "webpack@^4.36.0".
warning " > trumbowyg@2.20.0" has unmet peer dependency "jQuery@>=1.8".
warning " > css-minimizer-webpack-plugin@3.1.1" has unmet peer dependency "webpack@^5.0.0".
warning " > html-minimizer-webpack-plugin@3.3.0" has unmet peer dependency "webpack@^5.1.0".
warning " > terser-webpack-plugin@5.2.4" has unmet peer dependency "webpack@^5.1.0".
warning " > webpack-dev-server@3.10.3" has unmet peer dependency "webpack@^4.0.0 || ^5.0.0".
warning "webpack-dev-server > webpack-dev-middleware@3.7.2" has unmet peer dependency "webpack@^4.0.0".
[5/5] Building fresh packages...
Done in 89.02s.

merouane amqor is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

4

Digging deeper, I found a command that helps simplify the process of finding the correct peer dependencies i need :
npx check-peer-dependencies [--yarn|--npm] [--install] [--help]
npx check-peer-dependencies --findSolutions

source : https://www.npmjs.com/package/check-peer-dependencies