python – Errors in venv while installing packages using conda

I am getting errors like these when I run a requirements.txt file (CondaVerificationError, SafetyError, ClobberError)

CondaVerificationError: The package for icu located at C:Usersanaconda3pkgsicu-58.2-h9c2bf20_1
appears to be corrupted. The path 'lib/icu/current'
specified in the package manifest cannot be found.

CondaVerificationError: The package for matplotlib located at C:Usersanaconda3pkgsmatplotlib-2.2.2-py36h0e671d2_1
appears to be corrupted. The path 'lib/libtcl.so'
specified in the package manifest cannot be found.

CondaVerificationError: The package for matplotlib located at C:Usersanaconda3pkgsmatplotlib-2.2.2-py36h0e671d2_1
appears to be corrupted. The path 'lib/libtk.so'
specified in the package manifest cannot be found.

CondaVerificationError: The package for ncurses located at C:Usersanaconda3pkgsncurses-6.0-h9df7e31_2
appears to be corrupted. The path 'lib/terminfo'
specified in the package manifest cannot be found.

SafetyError: The package for ncurses located at C:Usersanaconda3pkgsncurses-6.0-h9df7e31_2
appears to be corrupted. The path 'share/terminfo/e/eterm'
has an incorrect size.
  reported size: 842 bytes
  actual size: 2267 bytes

SafetyError: The package for ncurses located at C:Usersanaconda3pkgsncurses-6.0-h9df7e31_2
appears to be corrupted. The path 'share/terminfo/e/eterm-color'
has an incorrect size.
  reported size: 1249 bytes
  actual size: 2267 bytes

ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/2/2621a'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/e/eterm'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/e/eterm-color'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/l/lft-pc850'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/n/ncr260vt300wpp'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/n/ncrvt100wpp'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p12'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p12-m'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p12-m-w'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p12-w'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p14'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p14-m'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p14-m-w'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p14-w'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p4'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p5'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p7'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p8'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p8-w'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p9'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p9-8'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p9-8-w'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/p/p9-w'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/h/hp2621a'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::ncurses-6.0-h9df7e31_2, defaults/linux-64::ncurses-6.0-h9df7e31_2
  path: 'share/terminfo/h/hp70092a'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::openssl-1.0.2o-h20670df_0, defaults/linux-64::openssl-1.0.2o-h20670df_0
  path: 'ssl/man/man3/bn_print.3'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::openssl-1.0.2o-h20670df_0, defaults/linux-64::openssl-1.0.2o-h20670df_0
  path: 'ssl/man/man3/hmac.3'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::openssl-1.0.2o-h20670df_0, defaults/linux-64::openssl-1.0.2o-h20670df_0
  path: 'ssl/man/man3/md5.3'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::openssl-1.0.2o-h20670df_0, defaults/linux-64::openssl-1.0.2o-h20670df_0
  path: 'ssl/man/man3/mdc2.3'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::openssl-1.0.2o-h20670df_0, defaults/linux-64::openssl-1.0.2o-h20670df_0
  path: 'ssl/man/man3/pem.3'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::openssl-1.0.2o-h20670df_0, defaults/linux-64::openssl-1.0.2o-h20670df_0
  path: 'ssl/man/man3/rc4.3'


ClobberError: This transaction has incompatible packages due to a shared path.
  packages: defaults/linux-64::openssl-1.0.2o-h20670df_0, defaults/linux-64::openssl-1.0.2o-h20670df_0
  path: 'ssl/man/man3/ssl.3'

I am trying to run CenterNet on my system and am encountering these error

Using conda clean --all and conda clean --packages --tarballs is not working.

How do I resolve this?

Leave a Comment